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Introduction

We created this program for use in my brother’s business as a guitar teacher back in the late 80’s.  I, Al Langston was the programmer and my brother, Duane the musician.  He provided all the specifications, testing, etc so we could get it done for his business.  We liked the program, so we decided to market it.  At the time this program was written, most tablature was performed by drawing lines and placing numbers on the lines using a text editor such as note pad.  

We created this program in DOS, then eventually brought it into Windows version 3.1.  Next we added a MIDI player and then brought it up to Windows 95.  Eventually we upgraded it so it now works on all versions of Windows from Windows 98 to Windows XP Pro.

Other tablature editors soon hit the market and being just the home business we were doing, it just didn’t develop into something we could pursue full time and in October, 2003 we took it off the market due to lack of sales.  We have had some requests to do a share ware, but I am choosing the free ware.  I do not want any money to be sent to me, because I do not intend to continue with this project, but instead put my senior years to use in more recreational alternatives.  I am not offering any technical assistance, because I currently have full time employment and really can’t continue with this project.  The exception is the folks who paid for the program when it was on the market.
We thank you for your patronage.  I am now releasing this program for free installation and use.  

Disclaimer – This program is out of production and testing.  Systems are constantly changing and with that, I can’t be responsible for the performance of this program.  Without continuing updating and testing with available systems, problems have a tendency to develop.  As of this writing, there seemed to be know known inconsistencies with this program and the Windows Operating system.

This manual was written some time back, and assumes that the program was purchased.  There are errors based on any updates since the writing of this book, but otherwise should be useful.  I am editing some inconsistencies from the book before this release, but I am not going to spend a lot of time re-writing the parts that do not matter.  I have added supplementary information in this PDF version of the manual.  The additions are in 12 point italic.  Because the format of the book has changed to 8.5 x 11 paper instead of the book format we were using, the table of contents is no longer valid.  
Enjoy.

Al and Duane Langston
Getting Started

If you purchased this program from us, you have been entered into our database and are eligible for technical assistance and we can provide you with upgrade information as it becomes available.  If you purchased this program from a vendor, please complete the registration card and return it to TABrite Software.  We will add you to our database.

This program uses the Windows operating systems.  You should have Windows 95 or later installed on your computer system and you should be somewhat familiar with Windows procedures, such as opening a file, navigation and file storage.  If you are not familiar with these procedures, the book will cover them briefly, but you may want to use other sources to familiarize yourself with Windows operations.

Follow the installation procedure to install the program, then, if desired, the CD contains over 200 sample songs that may be copied to your hard drive for your use.

You have most likely read tablature, seen it or are intimately familiar with tablature, however there are inconsistencies in the writing of tablature.  We have included a section on how to read tablature.  It is a good idea to review it before you begin.

The quickest way to become familiar with the program is by using the tutorial.  Not all the features are included in the tutorial, but it gives a quick overview of the program.  The program’s reference section thoroughly covers all of the program’s capabilities.

We have tried to write the manual as thoroughly as possible, while maintaining simplicity.  Still there is no substitute for spending a little time with the program.  Those of us, who have been using the program since its creation, have found it to be fast and easy.  With a little practice, you can enter tablature faster than by hand and (and much easier to read).



This chapter covers 

o Installation 

o File management

TABrite is designed to be installed in the Windows environment.  Users of Windows 95 will have to install version 4.2, while Windows 98 and subsequent editions should use version 4.3.  
DirectX, Version 8.1 is included on the CD.  If you are going to be installing TABrite version 4.3, and you do not already have DirectX, version 8.1 on your system, you must be install that as well as the TABrite program.  

DirectX, Version 8.1 or greater is required to run this program.  It may be downloaded from the Microsoft website if you do not have it currently installed on your computer.
System Requirements

o One CD drive (for installation)

o Hard drive with Windows95 or later installed Hard Drive with Windows 98 or later installed.

o 10 megabytes of free disk space.

o EGA or VGA monitor (runs best with higher resolutions, such as 1024x768)

Installation
The following section was designed to guide you through the set up using the CD.  Since you downloaded the program, you do not have the CD and some of the information is not valid.  You should be able to set up the program using the procedures described below by altering them to fit your custom installation.
Installation

Insert your CD into your CD drive.  If autorun is enabled, you will be presented with a screen as shown in figure 1-1, or similar depending on your Windows operating system.  The folder has options to install DirectX8.1, TABwin42 and TABwin43 and a folder of sample songs available to copy to your hard drive.  If this screen does not appear, use your  Windows Explorer to locate and highlight your CD drive.
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Figure 1-1

TABwin43 Installation

If you are installing TABwin43 and do not already have Direct X version 8.1, you will need to do that also.

Click the DirectX81 icon and you will be presented with a screen showing the available files in that folder.  Double click the “dxsetup” icon.  Accept the license agreement, and then on the following screen, click “Install”.

When Directx has installed, you will most likely have to restart your system.  

After restarting, return to the screen shown in figure 1-1.  Next install TABwin43.  Click the icon labeled TABwin43 Setup.  You will be presented a screen showing the programs in that folder.  Double click “setup.exe” icon.  The program will begin to setup.   Accept the license agreement and follow the instructions to complete the installation.

TABwin42 Installation

If you have Windows 95 (or Windows 98 and prefer to set up the TABwin42), click the TABwin42 Setup folder.   You will be presented with a screen showing the programs in the installation folder.  Click the “Setup.exe” icon.  The program will begin to set up.  Accept the license agreement and proceed following the installation instructions on the screen.

Sample Songs

The CD includes some 200 songs, pre-tabbed and ready to run.  If you desire, you may move these songs onto your hard drive for use with the TABrite program.  The simplest method to do this would be locating the TABrite music folder on the CD, then click and drag that to the root folder of your C drive.

If you are unfamiliar with creating folders, copying files, and navigating the file system using Windows Explorer, you should familiarize yourself with these techniques.  There are many good books that explain these principles.  The following file management principle might help you in navigating a place to put your music.

Principles of file management

File management is a technique that is learned after working with computers for a while, then realizing there are a lot of files out there and it becomes confusing to keep track of your files and where they are located.
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Figure 1-2

If you think of your hard drive as an office and in that office, you will have several file cabinets, each with several drawers.  In the drawers are hanging file folders and in each of the file folders, there are documents.  

In the example shown, the folder name 1MUSIC is named with a number at the beginning so that it will appear at the beginning of the file list.

The office, of course is drive C.   One of the file cabinets is called 1MUSIC.  It consists of file drawers “Banjo, Classical, Finger style, and Flat pick.  Notice that there are no spaces in any of the folder names.  It is allowed, but not suggested.

By clicking on any one of the folders, you will be presented a list of songs within that folder.  To copy your sample songs to your hard drive, just click and drag the folder TABrite Music on your CD to your hard drive. 

Sample songs are available on a number of web sites.

An Explanation of Tablature 


Tablature is an ancient form of musical notation that dates back over 2000 years, when it was used as a system for notating music for the lute. It has had a recent revival, and is gaining popularity for all fretted instruments. It is a simple number system that is easy to learn, but is not always consistent from one writer to another. There are many subtle differences, however, the general idea is always the same.
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Today tablature is used for four, five or six string instruments with frets. The staff is a group of four, five or six horizontal lines similar to a standard musical staff. The horizontal lines represent the strings of the instrument. The top string is the first string, which corresponds to the highest pitched string on the instrument.
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A number on a line is used to indicate the fret number, on which a finger is placed. The line on which the number is placed indicates which string the finger frets. If a “0” is in line 2, that indicates that the musician would pluck the second string open. If there was a 2 on line 4, that would indicate holding down the fourth string at the second fret, and plucking the fourth string. 
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Two or more numbers stacked one above the other indicates that the strings are plucked simultaneously.

Slurred notes, such as hammer-ons, pull-offs and slides can be represented by two numbers with a dash between them. Some tab writers prefer using the slur mark at the top of the numbers in place of the dash.

The example below shows both methods, one with the dash and the other with the slur mark. 
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Some tab writers prefer to put the two notes of a slur on the same stem, and some writers prefer a separate stem for each note of the slur. The following example shows how they can be entered on different stems. One example shows it with dashes and the other with slur marks.
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A letter below the staff is an editor’s mark used to tell the performer which technique is used to play a note. An “s” represents a slide, an “h” a hammer-on and “p” a pull-off. The lower staff can also be used to indicate right-hand fingerings such as “t” for thumb, “i” for index finger, “m” for middle finger and “a” or “r” for angular or ring finger.
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As in Standard notation, time values are determined by stems, beams and flags. A number with a stem and no flags or beams represents a quarter note and receives one count.

A flag or beam indicates an eighth note value and receives a half count. A double flag or double beam indicates a sixteenth note value and receives a fourth of a count. A dot behind a note is an abbreviation for half the value of the note added to the note. For example, a dotted quarter note receives one and a half counts.
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Triplets are represented by three numbers beamed or bracketed together with a “3” below them.
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A quarter note rest receives one count of silence.
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This is the symbol for an eighth note rest. It receives a half count of silence.
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This is the symbol for a half rest which receives 2 counts of silence
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This is the symbol for a whole rest. It receives 4 counts of silence.

In musical notation, a half note receives two counts and a whole note receives four counts. There is no standard way to represent whole and half notes using tablature. There have been a number of ways that have been used by different tab writers. A half note can be represented by two quarter notes connected by a tie. A whole note, a four-count note value in musical notation, can be represented by four quarter notes connected by ties.


[image: image15.png]



Some tab writer’s just use a quarter note with a quarter note rest following it to represent a half note and a quarter note with three counts of rest following it to represent a whole note.


Another method has been to put a circle or brackets around a quarter note to make it a half note, and the same symbol without the stem represents a whole note. A dot behind the half note makes it a dotted half, or three count note.
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Some tablature writers prefer to use Parenthesis for a tied note.
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An “X” is used to represent a muffled or dead note. 
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An arrow after a number is an indication that the note is “choked” or bent upward to a higher pitch. A downward pointing arrow means release the bend.
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An asterisk above a number indicates that it is a harmonic.

Double bars, double dots, D.S. al coda, D.S. al fine, D.C. al fine, first and second endings all work the same as their musical counterparts. 

Chord names are written above the staff just as they are in musical notation.


This chapter covers:

o Starting the program

o Exiting the Program

o Screen Layout

o The Menu System

Starting the Program

The setup program put an icon on your program list.  It may be started like most other Windows programs. Click the “Start” button, and then move the cursor to “Programs”.  A pop out will display a list of programs available to run. Locate TABwin43, and click the program.  

The program should begin to run.  You will get a “Splash” screen, which will display the version information and copyright.  Click the Continue button to proceed or you can wait and it will time out.  You will then be presented with the main TABwin43 screen.  You are now ready to begin using the program.

Screen Layout

The TABrite screen consists of the following parts:

o Title bar

o Menu bar

o Work window

o Display window

o Refresh button

o Time value button

o Measure advance button

o Measure counter

o Entry record
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Figure 3-1

Display Window
The display area is the section of the screen that displays larger sections of the song.  Entries and changes are not made in this window, but rather in the work window.  This window is just for viewing the song without having to scroll through the measures.

Refresh Button

Since entries are not made in the display screen, but rather in the work window, the changes you make in the work window are not reflected in the display window until the screen is refreshed.  This button updates the new entries or changes you have made.                       

Time Value Buttons

The time value buttons are used to change time values by using the mouse.  They are also highlighted to show the current time values while using keystrokes to change time values.

Measure Advance Buttons

These buttons move you forward and backward through the tablature a measure at a time.

Measure Counter

The measure counter keeps track of which measure you are on, since only the current measure is displayed in the work window.  As you click forward and backward in the song, the measure counter changes to reflect the currently displayed measure.

Entry Record
Just below the measure counter there is a box labeled “Last Note”.  There is a number displayed in the box letting you know how many records are in the data file.  See the section on data limitations.

Title Bar

In addition to telling you the name of the program, the title bar lets you know the instrument for which the program is set and contains the standard Windows minimize, maximize and close buttons.

Data Limitations    


An entry is defined as a rest, a number or group of numbers on a stem.  Each entry in the program requires one data record.  In addition, each measure requires one data record to store information such as repeats, double bars and remarks.  In the upper right of the work screen, you will see a display that says “Last Record.”  There is a number displayed beside it, telling you how many entries have been made.  There is a limit of 1500 entries for the song, therefore, on long songs, you need to watch that closely. 

If you exceed that limit, you will get a message “Subscript Out of Range”.  If your song has 160 entries in 20 measures, the number of records required for the song will be 180.  This limitation will accommodate most songs, however, should you need to enter a song of greater length, you could enter it in two parts and leave the title off the second, and name the file “title2” 

Tablature entry problems

Tabrite is not a word processor, nor is it foolproof. It doesn’t check the musician’s ability to write music correctly. It will automatically close a measure when the beat count equals a full measure, however, it is possible to enter more or less beats than is musically allowed. In the hands of a musically literate person with at least a basic knowledge of computers, this program will produce excellent tablature. If the user enters improper rhythm, Tabrite may beam the notes in an unpredictable manner. 

Tabrite automatically stems and beams by the rules of standard musical notation. For example, 4/4 time divides the beam by the quarter note value. 
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Another of the program’s limitations is that the note values only go as small as “1/16”. One way to overcome this, is in a song that uses “1/32” notes, double the values of all notes in the song, and double the number of measures. For example, a measure containing 32 32nd notes can be written as two measures, each containing 16 16th notes.  

IMPORTANT-  <NUMLOCK> must be enabled in order to enter tablature using the numeric keypad. 


After entering a full measure of tablature, the cursor no longer remains in the staff. Focus is shifted to the Next Measure button.  At this time, if you choose to enter chords or lower staff editing marks, you must first mouse click somewhere in the staff. 

When entering musical terms such as “D. C. Al Fine”, they appear to be to the right of the measure, on the screen. However, in print, they are in the correct measure.

When entering stacked notes (simultaneously played notes), a stem appears after the second note is typed in. Disregard this and continue entering until you have all of the notes of the stack, then press the <ENTER> key. At this time, the correct time value will be attached to the stem. 

Every attempt has been made to eliminate “bugs.” Since we created this program, we use a method of tab entry that never fails for us. However, everyone has there own individual style of entry, so there may be bugs we are unaware of. Any that we know about, and have been able to duplicate, we will find a solution for. If you have trouble with printing a particular piece and the problem appears to be in a particular measure, if you can’t seem to eliminate it, try deleting the measure and reinserting it.  

The Menu System

Figure 3-2

The menu system allows access to most functions available in the program.  Each menu will be covered in detail.
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Chapter 4 covers

o Selecting an instrument

o Opening a song

o Expanding the Page View

o Printing a Song

o Exiting the Program

Chapter 4 and 5 are a tutorial for the program.  Completing these two chapters will introduce you to most of the functions available in the program.

TABrite Tutorial - Lesson # 1
Selecting an Instrument
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When the program is run the first time, the default is for the Guitar.  When the user begins to write the tab, or open a pre-tabbed piece, the program will assume that the guitar is the instrument of choice.  To change that, select the instrument menu, click the preferred instrument.

For this lesson, we will be selecting a guitar piece, however if you want to select a banjo piece, go ahead and select banjo on the menu.

Opening a pre-tabbed Song
If you installed the pre-tabbed songs or if you have downloaded some songs from the internet, you may open those songs, edit them, print them, and/or play them back.  To open a song, click the File menu, then click Open.  You will be presented with a screen shown in figure 4-2 or similar, depending on your operating system.
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figure 4-2

Use your Windows navigation system to locate the file that you want to open.  In the above case, the music files from the CD are located in the folder C:\MUSIC.  

This example will use the file “Scarborough Fair”, which happens to be in the “Fingerstyle” folder.  Click the Fingerstyle folder, then click “Scarboro.gui” from the list.  

Click Open or double click the file.  If you followed along with the book, you should have a screen similar to figure 3-1.  The song “Scarborough Fair” is displayed in the display window and the first measure of the song is displayed in the work window.

Expanding the Viewing Area
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The Page menu is used to expand the page to see more of the display.  The large view will expand the work window to its maximum size.  Click the “Page” menu, then click Large View.  The remaining part of “Scarborough Fair” is displayed.  If the song goes on to multiple pages, you can use the Page Down selection to get second and subsequent pages.  To return to the normal screen, click the Page menu, then select Small View.

Printing the Song 
The song can now be printed using the standard Windows printing dialog boxes.  From the File menu, select Print.
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A windows dialog box will be presented to you, resembling figure 4-4, depending on your Windows version.  Click Print to print the song.  
Figure 4-4

You can play the song using your MIDI system.  See the “Playback” section for more information.

Exiting the Program
To Exit the program, click the File menu, then click Exit or click the “X” on the upper right corner.  If a song is left un-saved, a warning screen will inform you and ascertain whether you wish to save the file.



This chapter continues the tutorial.  This chapter will contain several lessons on entering and editing the tablature.

Lesson # 2 will cover the following topics.

o Setting Up a Page

o Time Signature

o Starting a new song

o Entering a Title and Credits

o Page Setup

o Refreshing the Display Window

o Entering tablature

o Changing Time Values

o Correcting Errors

o Saving the Piece

Entering Tab

During this chapter, we will be entering some tab for the banjo.  Go to the instrument menu and select banjo as described in chapter 4 (Selecting an instrument).

Time Signature  

The time signature is changed when you mouse click on the number that you desire to change.  You should always change the bottom number first.  For example, the time signature always defaults to 4/4.  If you want to change it to 6/8, click the bottom number.  It will change to “8”.  The top number will change to a “3”.  To change that to a “6”, click it.  

The bottom number will alternate between “4” and “8” with every click.  When the bottom number is an “8”, the top number will alternate from “3” to “6” to “9” to “12” with every mouse click.  When the bottom number is a “4”, the top number will alternate between “2”, “3”, “4”, “5” and “6” with every click.  

When “New” is selected from the file menu, or a new instrument is selected from the instrument menu, the time signature will default back to 4/4.

Starting a New Song

To start a new song, click the File menu, then click New.  This will start a fresh new song in 4/4 time, and since banjo was selected as the instrument of choice, the work window displays 5 lines corresponding to the 5 strings of the banjo.

Setting Up a Page
To set up a page, click File, then click Page Setup.
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Figure 5-1
The above screen will be displayed.  On this page, you may assign a title to your song, credits, adjust the fonts and select your margins and stave spacing.  Default font for the body is Arial at 12 point.  To change the setting, click Change Body Font You will be taken to the standard Windows font dialog box to select available fonts on your system.  The fonts available for this program are 8, 10 and 12.  Any other fonts will revert to 12 point.  The Title font is selected the same way.  Click Change Title Font to select a font and font size for the title.  The title font is not restricted to the font sizes named above.

Use the margins and spacing to space the top, left and right margins.  You may also adjust the stave space if desired.  When all changes to the page setup have been completed, click the exit button.  All changes will be complete.  When you return to the main screen, if you made changes to the title or credit, you will need to refresh your display window to see the changes.

For our learning example, enter a title in the title box and credits as desired.  For this example, enter “My First Tab” in the title box.  Press <TAB> or click in the first Credit text box.  Enter “Arranged by Me” then tab or mouse click in the second credit text box and enter “Standard Tuning”.  Click Exit to leave the screen and return to your song.

Refresh Button

The Refresh Button is located in the center and to the right side of the screen.  The Refresh Button is used to refresh the display window.  Click the refresh button and you will see the title and the credits that you put in.  The display window is not refreshed after every note.  After entering measures, you will use the refresh button often to update the display window.  This enables the slower computers to not have to update with every keystroke.

Entering Tab

Tablature is entered in the work window in the lower left area of the screen.  To enter basic tablature, you will need to select a note value, move to the desired string, then type the number followed by the <ENTER> key.  

It is recommended that you put in all the tablature for the song, then go back and add things like remarks, chords and editing marks.  Tablature is very quick because you can do most of it without jumping from the ten key pad to the function keys to the mouse.  

Most tablature can be inserted entirely on the ten key pad and arrow keys next to the ten key pad.  Some of the other functions are a little more complicated and require the use of the menus or mouse to get around.

Entering “1/4” notes
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For our learning exercise, we will put in the measure shown at the left.  Using the arrow keys, move the cursor to the third string.  Type “0”, hit the <ENTER> key, then type a “2” then hit the <ENTER> key.  With the arrow key, move to the second string and type “0”, hit the <ENTER> key, then type “1” and hit the <ENTER> key.  You have just entered your first measure.  (Note:  if the cursor fails to respond to the arrow keys, you have lost focus in the work window.  Just click with the mouse in the work window to gain focus.)

You can use your mouse to place your cursor on the desired string, however, you will find if you get used to using the arrow keys to place your cursor, you can get very quick at entering tablature.  Notice that as you hit the <ENTER> key, the note was stemmed and the cursor moved to the next position.  Also notice that when you hit the <ENTER> key on the last note, the focus was moved to the NEXT button.  

The reason for this is, the program knew that you completed the measure, based on the time signature and the notes that you entered.  Nothing is in the display window.  Click the REFRESH button and your measure will be placed in the display window.   Click NEXT with your mouse to move to the next measure.  You will be given a clean work window, ready for the next measure.

Entering “1/8” notes and “1/16” notes

The note value buttons are located at the center of the screen, just above the work window.  Observe that the note values start with a ‘“1/16”’ triplet, then range to a whole note.  These note values will accommodate most songs.  

There are two ways to change the value of the note being typed.  One way is to click the value of the note.  The other way is on the 10 keypad, we have made some short cuts so that you do not have to leave the keypad, just to change a note value.  It may seem a little complicated at first, but once you get used to it, the process is quite simple.

The “+” key will advance the note value around from “1/4”, to “1/8” to “1/16” notes.  Each time the “+” key is pressed, you will toggle to the next note value.  

The asterisk key will change the note value to a triplet.  For example, if you have selected the “1/8” note, when you click the asterisk key, the note value will change to a “1/8” triplet.

The period key will change your note value to a dotted note of the same value.  For example if your note value is “1/8”, clicking the period key will change your note value to a dotted “1/8” note.  

This may sound a little confusing, so try using those buttons to select some note values.  With practice, it is easy and notice you can do it all from the ten keypad.
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The next measure to add in our lesson is the one shown below.

You can use your mouse to change the note values, then just click the number, or you can use the keypad as described above.  To use the keypad, follow the following steps very carefully.  This assumes the note value is currently a “1/4” note.

Press the “+” sign twice to set the value to a “1/8” note.  Type “0” <ENTER> twice.

Press the “+” sign twice to set the value to a “1/16” note.  Type “2” <ENTER> four times.

Press the “+” sign once to set the value to a “1/8” note.  Type the asterisk to change to a “1/8” triplet.  Type “4” three times to enter the set of triplets.

Type the period to change the note value to a dotted “1/8” note.  Click the up arrow one time to move to the 5th string.  Type “0” <ENTER>
Type the “+” sign twice to move to the “1/16” note.  Type “0” <ENTER>.  The measure is complete.

Click the Refresh button to display your work in the display window.

If you are following along with the lesson, you are probably about ready to take a break.  You should save your work and exit the program.  (You really do not have to exit the program, but for this example, you should, because we are going to introduce something new).

Saving your work

Click the File menu, then click Save As.  
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Figure 5-2

Figure 5-2 shows the standard Windows save as dialog box.  Navigate to the folder where you want to save your work.  Type a name for the file.  The example shows “My First Tab” as the file name.  The .bjo extension will be added to the file name indicating it is a banjo file.  Click the SAVE button.

Exit the program as described in chapter 4 (exiting the program). 
Lesson #3

In this lesson, you will be introduced to

o Appending to an existing song

o Entering rests

o Symbols

o Editing a song

o Changing a note from one string to another

o Changing note values

o Entering Stacked Notes

o Deleting a note

o Deleting a measure

o Inserting a measure

o Changing a rest to a note and a note to a rest

Appending to an existing song

If you exit a piece and later return to the piece, you will not be in the mode to enter new measures.  To return to the enter mode of operation, click the File menu, then click Append.  You will be placed at the end of the piece, ready to begin inserting measures again.

If you are following along with the exercise, continue on.  Now it is time to get back to it.  I closed the file, so we will need to retrieve it.  Use the procedures from chapter 4, (opening a pre-tabbed song) to retrieve the song you just saved.  

When the song opens, you will observe a slight difference in the actions of the program.  Use the Next and Previous buttons to scroll through the song.  The peculiar thing is that you never get a blank measure to enter new tab.

This is easily solved.  Click the File menu, then click Append.  Now you are back into to the entering mode as you would have been, had you not exited the program.

 Entering Rests

There are three ways to enter a rest.  First you need to select the value of the rest by selecting the note value.  For example, if you want to enter a “1/8” note rest, you would set your note value to a “1/8” note.  Next, enter the rest by using one of the following methods.

o Click the rest symbol, next to the note value buttons.

o Click the <F4> key.

o Click the Symbols menu, then click Rest.

If you are following along with the exercise, we need to put in some rests in the next measure.  The measure we are going to add is displayed below:
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To insert this measure, move the cursor to string 5 and be sure the note value selected is “1/4”.  Type “0” then <ENTER>.  The cursor is at note 2, click the <F4> key.  This is the short cut for the rest symbol.  After selecting the rest, the cursor moves on to the next position.  Now we want to insert a “1/8” rest.  To do that, click the “+” sign twice to move the note value to “1/8” or click the “1/8” note value key.  Type the <F4> key to insert a rest.  A “1/8” rest is inserted.  

The rest inserted by clicking the <F4> key is the same value as the note value keys.  Continue entering the measure by moving the cursor to string 1, type “4” <ENTER>, then select “1/16” note value by clicking it or hitting the “+” sign to move the cursor to the “1/16” note value.  Type the <F4> key.  Enter the last note by selecting the dotted “1/8” note value and type a “2” <ENTER>.

Next, refresh your screen by clicking the Refresh button.

Congratulations, you have now learned all about entering rests.  You should at this time be fairly comfortable with moving about note values and entering the notes.  

Try it by entering the following measure:
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Remember to select the note value for the “1/4” note before beginning.
Double Bar

To enter symbols, use the Symbol Menu and select Repeat Sign, Repeat Start, Double Bar or Begin Double Bar.  In the exercise, select the double bar to show the end of the piece.  The symbols are all a toggle.  If there is a double bar, clicking the double bar in the symbols menu will turn it off.  If there is no double bar, clicking the double bar will put one into the song.

Editing a Song

Changing a note from one string to another

If you have been following along with the lessons, you have entered a song that looks like the following:
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Figure 5-3

If you have closed the song, you should reopen it and move to the first measure.  If you have not closed the song, then scroll to the first measure using the Previous button.

The first measure is incorrect and needs to be changed to appear as follows:

[image: image35.png]



To edit the first measure to look like the one at the left, use the arrow keys and move to the second note.

Press the delete key.  Observe that the note value disappears and is replaced with a stem through the staff.  Press the down arrow to place the cursor on the second string.  Type “7” <ENTER>.  Observe the fret number was placed and the stem is corrected.  Move to the last note using the right arrow key or click the mouse on the “1” on the last note.  Ensure the cursor is on the fret number and press the delete key.  Move the cursor to the third string and type “5” <ENTER>.

Changing note values

The next change is to change note values.  The example will change the last measure of the song 

From this


To this
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To accomplish this, change the first note to a “1/8” note.  Place the cursor on the first note in the measure.  With the mouse, click the “1/8” note in the note value button bar.  Observe that the note changed to an eighth note and beamed to the second note.

Move to the second note.  Ensure the cursor is next to the “1” in the second note.  Click your delete key.  Move to the third string and type “5” <ENTER>.

Move to the fourth note of the measure.  Change the value to an eighth note by clicking the “1/8” note value on the button bar.
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Your measure should look like the measure on the left.  

Ensure your cursor is next to the “2” on the fourth note.  Click the <DELETE> key.  Move to the fourth string and type “7”.  

Move to the last note of the measure (This is an empty note). Depending on how you entered your song, the cursor may not go to the empty note.  If it doesn’t, place your cursor on the last note.  On the “EDIT” menu, select “INSERT NOTE AFTER”.  This will place you on the empty note.  Click the “1/4” note on the button bar to set your note value to a “1/4” note.

Entering a Stacked Note

Move the cursor to the first string and type “0”.  DO NOT HIT THE <ENTER> key.  Arrow down and type “0”, then arrow down to the fifth string and type a “0”.  

If you made a mistake and you have a measure that looks like this:
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Just put your mouse on the last note of the measure and click the “1/4” note on the button bar.  The note will change to the proper value and the measure will close.

Deleting a note

You may have noticed that hitting the <DELETE> key does not actually delete the note, but rather deletes only the number on the line, replacing the deleted note with a blank stem indicating a blank note.  You may, however want to delete a note entirely.  We will do that now with measure number 3.  We will change measure number 3 

From this 


To this
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Position the cursor at the last note of the measure.  Change the value of the note to “1/4” by clicking the “1/4” note value button.  

Press the left arrow to move to the “1/16” rest.  Click the Edit on the menu bar, then click Delete Note.   Observe that the “1/16” rest goes away.   

Now move to the “4” on the previous note.  Change the value of that note to a “1/4” note by clicking the “1/4” note value button.

Move the cursor to the “1/8” rest on the previous note.  From the Edit menu, click Delete Note.  

Deleting a Measure

Sometimes a measure will require so many changes that it is easier to delete the measure and re-insert it.  This is the case with measure number 2.

Move to the second measure by clicking the Previous button.

Select Delete Measure from the edit menu.  Click the refresh button and observe that measure number 2 is gone and measure number 3 is pulled back into the measure number 2 position.

Inserting a Measure

To insert a measure, from the Edit menu, select “Insert Measure”.  A blank measure labeled “Measure No: 2” will appear on the screen.  Notice that the “Refresh” button has been disabled and the previous and next buttons have changed to “Cancel” and “OK”.  Enter the following measure using the methods that you have learned:
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After you have entered the measure, click the “OK” button, then click the “Refresh” button to insert the measure.

Changing a rest to a note and a note to a rest

To change a rest to a note, go to the third measure of the song.

Change this


To this
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To accomplish this, go to the third measure of the song.  Move to the first note and pres <F4> or click the rest symbol on the button bar.  Notice that the note changes to a “1/4” rest.  Move the cursor to the second note.  Move the cursor up to the first string and type “4” <ENTER>.  The note appears and the rest disappears.

TABrite Lesson #5

In this lesson you will learn how to:

o Enter a repeat sign

o Enter 1st and 2nd ending brackets

o Enter a D.C. al Fine

o Enter a Fine

o Enter Chords

o Enter slurred notes

o Enter left-hand editing

o Enter right hand editing

If you are not in the program, enter the program and bring up your sample piece.  If you have been faithfully following along, it will be called “My first Tab”

We will begin by inserting a measure between measure 3 and measure 4.  Select the Insert Measure from the Edit Menu.  Now enter the following measure.  (See Lesson #4 – Inserting a measure).  Click the OK button
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IMPORTANT – After inserting all of the measure, it is essential that you click the OK button prior to entering other entries such as chords, repeat brackets, and lower staff editing marks.  They can be added after clicking “OK”.

Ensure you are on measure 4.  If you are not, move to measure 4 using your measure advance buttons.  

Click on the Symbols menu, then click “Repeat Sign” or press the shortcut <F6>.  Refresh your screen and note that a repeat sign is displayed at the end of measure #4.

The repeat sign is a toggle.  When you click the “Repeat Sign” choice on the symbols menu or click the <F6> key, the repeat sign will turn on if it is not on or turn off it is on.  

Repeat Brackets

Repeat brackets or repeat endings is another toggle, selected from the endings menu or the short cut key <F7>.  To install the first repeat bracket, ensure that you are in measure number 4.  Press the <F7> key or select “Repeat Bracket” from the “Endings” menu.  Type “1.” <ENTER>.  Refresh your display window to see the results.  

It is very important that you enter the repeat ending correctly.  The MIDI player will be looking for the ‘1.’ in the repeat bracket.  The Period following the “1” is very important.

Move to measure #5 and follow the same procedures to enter the second repeat bracket.  Press <F7> then enter “2.”

D.C. al Fine

The D.C. al Fine may be placed in a song by using the D.C. al Fine selection on the Endings menu or by pressing <Shift – F2>.  On the work window, it may look out of place, but it will display correctly in the Display window and will print correctly.

Ensure measure #5 is still selected.  Press <Shift – F2>.  Refresh your screen to see the results.  A “D.C. al Fine” is placed at the end of measure #5.

The remainder of the endings work in the same manner.  They are all toggles (They turn on/off with the click of the choice or the function key) and are all located in the “Endings” menu.

Fine

If you have a “D.C. al Fine”, you MUST have a “Fine” by musical rules.  Failure to enter the “fine” will cause an error in Tabrite during the creation of a playback file.   Go to measure #2 through one of the available methods.  Install a “Fine” in the measure by selecting “Fine” in the “Endings” menu or by using the shortcut key <Shift – F3>,  

Also in measure #A2, install a double bar by selecting “Double Bar” in the “Endings” menu or by the shortcut key <F9>.  Click refresh to see the results.  You should now have a display that looks very similar the following:
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Figure 5-4

Entering Chords

To enter a chord, locate the cursor in the note for which you want to enter a chord.  Press the <F1> key or from the “Edit” menu, select “Chord”.  The cursor will move to a position above the staff.  Type the chord name (such as “C” or “D7”), the press the <ENTER> key.

Move to the first measure of the song.  The cursor should be positioned at the first note.  Press <F1>.  The cursor moves to a position above the staff.  Type “G” <ENTER>.  Notice that the “G” chord is entered in the position above the first note.  Click “Refresh” to see your results in the display window.

Press the right arrow three times to move to the forth note of the measure, or mouse click on the fourth note.  Press <F1> to move the cursor above the staff and type “C” to enter a “C” chord.

Click the “NEXT” measure advance key to move to measure #2.  Your cursor should be on note #1 of the measure.  If not, move it there, using the arrow keys.  Press <F1>, then type “D7” <ENTER>.  The D7 chord is entered above the first note of the second measure.  Click the “Refresh” button to see your results.  Using figure 5-5 as a guide, enter the remaining chords.  Position the cursor to the note requiring the chord, press <F1>, then the chord to enter the chord names above the staff.  Click the “Refresh” button at any time to review your work.

Entering Slurred Notes
We will complete the tutorial, by putting in some slurred notes, tied notes, and some left and right hand editing.  See figure 5-5 to view the final product.
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Figure 5-5

The first slurred note to enter is in measure #4.  It is displayed as a 2-0 indicating a pull-off.  Go to measure #4 using your navigation techniques learned earlier.  You should be on note #1 or measure #4.  Type “2-0” <ENTER>.  This example demonstrates using a dash between the notes to indicate a pull off.  If you prefer to have a curved symbol, use the “=” sign between the notes.  Refresh your display to see the results.

Tied Notes

Tied notes are shown as a curved line from one note to the next.  The tie is inserted in the song by holding the shift key down while typing the number “6”. 

To demonstrate this, we will connect the “4” on the second beat to the “4” on the third beat in measure #3.  Go to measure number 3 using the measure advance buttons.

Place the cursor on the second beat of the measure.  Type “4^” (shifted 6), then <ENTER>.  You may observe in the work window, the tie between the two notes.  

To remove a tie, go to the note for which you want to remove the tie.  Type the number without the “^” symbol and the tie will be removed.

Left and Right Hand Editing Marks

Sometimes it isn’t clear what kind of left-hand technique is used on a slur, so we enter an editors mark below the staff.  Return to measure #4.  Ensure the cursor is on the first note of the measure.  Select “Left-Hand Editing” from the “Edit” menu, or use the <F3> short cut key.  Only a single character can be entered here, so type a “P” indicating “pull-off” and press <ENTER>.  

Move to measure #5.  Sometimes you need to specify right-hand fingers that are used to pick particular notes.  With the cursor on the 1st note in measure 5, slect “Right-Hand Editing” from the “Edit” menu, or use the <F2> short cut key.  Type an “M” for the middle finger and press <ENTER>.  Move the cursor to the second note of the measure and use the <F2> key to move the cursor below the staff.  Type a “T” for thumb and press <ENTER>.  Repeat this procedure and type an “I” for index under the third note, a “T” under the forth note, and and “i” under the fifth note.

Refresh your screen and note that your display looks like figure 5-5.  If it doesn’t you may have to go back and correct your mistakes.

Save your work, print out a copy and exit the program.

This completes the tutorial  There was a lot of information put out in this tutorial and it will take a lot of time to learn all the short cuts.  We do suggest, however that you enter all the notes first, then go back and put in chords, editors marks, and all the special characters and remarks.  That way you can stay on the key pad for most of the song.  After the notes are all in, then go back and use the menus to put in the special symbols and marks observing the short cut keys.  After awhile, these will become second nature.


The Midi playback is used to listen to the songs that you create or to listen to songs that you have downloaded from the internet.  The midi screen is shown below in figure 6-1.  
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Figure 6-1

Prior to using the MIDI playback, you must open a song in the TABrite main screen.  Using Chapter 4 as a guide, select the instrument of choice, then open the song that you want to hear.  If you have just created a piece and want to hear the piece you created, be sure to save it before playback, just in case.

The MIDI screen consists of two areas.  The top area is to create the MIDI playback and the bottom area is to actually do the playback.  

See figure 6-1.  The top left part of the window displays the sound.  If you have selected “Guitar”, then it will be defaulted to the Acoustic Guitar.  To the right of the sound, will be the tunings.  Generally, you will not have to change this setting.  The default is for the standard guitar tuning if your instrument of choice is the guitar, or the standard banjo tuning if your instrument of choice is the banjo.  Either of these may be changed by clicking the “Down” arrow key next to the text.

To the right of the tunings is the capo.  You can place the capo on any fret from 0 to 12 by moving the slide.

Below the sound selection is the tempo selection.  You may select the tempo by moving the slide, observing the tempo in the text box next to the slider.

With the MIDI builder, you have a choice of building a play file or building a MIDI file.  The default will always be the “Play file”.  You may change that by selecting the corresponding radio button in the “Build Type” frame.  Generally, you will select the “Play file”.  The only reason to select the MIDI file would be to build an actual MIDI file that can be played on any MIDI playback system.

To build the file click “Create Play File”.  This will build your MIDI playback for you.  When the MIDI file is built, the name of the file will be indicated in the text box, just below the “Create” button.  Generally, it will indicate “Playfile.mid”.  

The MIDI player is located just below the MIDI builder.  Click “Play to play the tune.  During playback, you can adjust the tempo to your liking, as well as the master volume during the playback.  If you want to repeat the playback, click the “Loop Audio” check box to the right of the master volume.  Note:   You have to stop the MIDI playback to select the “Loop Audio”.  

The Tempo slide bar in the MIDI builder area is only used to specify the initial build tempo.  Once you determine the approximate tempo, or if you want to change tunings, sound, etc, you can click “Clear MIDI” in the MIDI builder area of the Window.  At that point, you can adjust the master tempo, sound, tunings or capo.  Next click “Create Play File” to re-create your MIDI playback.


Selecting an Instrument

· Click Instrument Menu

· Click your choice of instrument

When you begin the program, select an instrument from the Instrument Menu.  Using this function will change your instrument to your desired selection.  This will initiate a new song when the instrument changes.  You will be prompted, if you have unsaved work pending.

The selections include Guitar, Banjo, Bass/Mandolin which will give you 4, 5, or 6 strings on the staff.

New File

· Click File Menu

· Click New

To begin a new song select New from the File Menu.  You can use this function to abort the current song.  If you have made any changes to the current song, you will be provided a warning stating the file has not been saved and prompt you whether or not to continue.

Opening an Existing File

· Click File Menu

· Click Open

To open an existing file, select Open from the File Menu.  A dialog box will open displaying only the files for your selected instrument.  Use the standard Windows navigation techniques to locate the song to open.  Once found, highlight the song by clicking, then click “Open”.  

The first measure of the file  will be displayed on the work screen and the full song will be displayed in the display area.

Append

· Click File Menu

· Click Append

Once you have saved a song and exited the file, it is assumed that the song is finished.  When you open an existing file you may modify it in any way (with the edit functions), but to add to the end of it, select Append from the Edit Menu.  The cursor will be appropriately placed in the first note position of the next measure in sequence, and you can complete the song.  You can stop entering a song at any point, save the file, exit the program and return later to finish it with the Append.

Page Setup

See Chapter 5 (TABrite tutorial lesson #2).  The page setup will allow the user to enter the title, credits and define margins and spacing.  Fonts for both the body and the title can be chosen.  Figure 5-1 shows the screen.  After filling in the information, just click “Exit” and you will be taken back to the main screen.  When the screen is refreshed or when you print the song,  the fonts and settings from the page set up will be used.

Displaying & Refreshing the Song in the Display Window

When you open a file, the entire song can be viewed through the display window, about three lines at a time. You simply scroll down through the song. Only one measure is displayed in the work window. When you edit a measure, or enter a new measure, the changes are not reflected in the display window. If the program did that, the redraw time would make the program so slow it would be impractical. When you are entering or editing a song and wish to view the changes or additions you have made, click the “refresh” button below the display window. The changes you have made will now show up in the display window. You may refresh the window as often or as you need for reviewing your work. When you start a new file, all entries are made in the work window and nothing is in the display window until you click the refresh button.

Page - Large & Small & Page
If you want to see only the display window (for the purpose of seeing a larger section on the screen without scrolling through the song) you may select “large view” from the view menu. To add to or edit the song, you will need to have the work window back. To do that, select “small view” from the view menu. 

There is also a “page” selection in the page menu. This toggles from page to page on files that are too long to display on a single page.


The display you see on the screen is not necessarily the same line and page layout that will come out on the printed page. The printout will be affected by the font size, style, page break locations, etc. that you select. The display window is just for the purpose of checking your work without actually printing. 

Save

· Click File Menu

· Click Save As  

When you are finished entering a song, or want to quit and return to finish it another time, you will probably want to save your work.  Select Save As from the File Menu.  A dialog box will open.  Type in the name you would like to call the file.  It must be eight or less letters.  Don’t enter the extension.  The program will add it for you, using .gui for guitar songs, .bjo for banjo and .bss for bass or mandolin.  Make sure you are in the directory and drive where you would like to save the song.  Click the OK button. 

If you have already saved a file and want to save changes that you have just entered, select Save from the File Menu.

Time Signatures
When you select an instrument and/or a new file, a work screen with four, five or six strings appears.  At the beginning of the displayed measure there is a time signature.  The default time signature is 4/4 time.  To change the time signature, mouse-click on the bottom number until you have the change you want.  It will toggle through all of the possibilities one at a time as you click.  Do the same for the top number. If you are changing to a time signature where both top and bottom numbers need to be changed, you must change the bottom number first. When you have the desired time signature, begin entering your song. You may also change time signatures in the middle of the song if it calls for such a change.

Moving through the Measures

Measure Advance Buttons and Measure Counter

You can move backward or forward through the measures of a song by clicking the Next Measure or Previous Measure buttons.  This moves you through the song one measure at a time.  The measure counter in the lower right of the screen will show the current measure number.  If you want to go directly to a specific measure number, click on the number just to the right of the measure counter, type in the measure number you want to go to and press <ENTER>.

If you are entering tablature and you are at the last measure you entered, clicking the Next Measure button will move you to a blank measure, ready to enter tablature in the new measure. Immediately after entering the last note of the measure, the Next Measure button is in focus, so you can just press the <ENTER> key instead of clicking the Next Measure button. If you open a file, you will be in the display/edit mode. When you reach the last entered measure and click the Next Measure button, you will be returned to measure number one. If you choose to add to the song, you must select Append from the File Menu.

Printing a File
· Click File Menu

· Click Print

To print a file, select Print from the File Menu.  A dialog box will open prompting you for the number of copies you want. Type in the number you want and click the OK button or press the <ENTER> key. You may want to click the setup button and change paper sizes, printer orientation, etc. Before sending a file to the printer, you might want to chose some page setup options. (see Page Setup, Chapter 5.)

Exiting the Program
· Click File Menu

· Click Exit 

Entering Title and Credits
· Click File Menu

· Click Page Setup

At any time you may add a title or credits to an open file.  Select Page Setup from the File Menu.  Type in the title you want to appear at the top of the page. DO NOT USE QUOTATION MARKS IN YOUR TITLE. It will cause the file to not open. You may backspace to correct mistakes.

To go to the credit boxes, use the <TAB>.  You may enter composer, arranger, recorded source, tempo, etc. in these boxes.  When you have completed your entries, Click “Exit”

To change an existing title, select “Page Setup” from the “Edit” Menu.  When the box with the title and credits appears, tab to the box where you want to make the change, type in your text, and click “Exit”.

Entering Tablature
Selecting the String

To move to the string on which you want to enter a number, press the up or down-arrow keys.  The cursor will move up or down on the lines of the tablature staff.  If you are pressing the up-arrow and you are on the top string, the cursor will wrap around to the bottom and go up from there.  The down-arrow key moves the cursor down through the lines of the staff and it also wraps.

Another way to select the string on which you want to enter a fret number, is to mouse-click the string you want. 

Selecting the Note Value

When you have selected the string on which you want to enter the tablature, you need to select the time value you want before entering the note.  The time value can still be changed after the tab has been entered. (See the Editing section.) 

There are two ways to select the time value.  You can use the mouse and click the desired note value from the selection of buttons on the screen, or you can use the numeric keypad.  The keystrokes are a little more complicated to memorize, but much faster when you are used to them.  

To change time values, use these keys:  “+”, “*” and “.”  from the numeric keypad.  The “+” key toggles between “1/4”, “1/8”, and “1/16” note values.  As you press the “+” notice time values as they change focus, reflecting your current selection.  To select a triplet time value, press the asterisk, “*”, key on the numeric keypad.  If you want “1/8” note triplets, make sure you toggle the “+” key to “1/8” note value before pressing the asterisk key.  If you want “1/16” note triplets, toggle the “+” key to “1/16” note value then press the asterisk key.  If you want to enter “1/4” note triplets, toggle the “+” key to “1/4” note value then press the asterisk key.

To enter dotted-note values, we use the period, “.”, key on the numeric keypad.  If you want a dotted “1/4” note, toggle the “+” key to “1/4” note and press the period key.  For dotted “1/8” note values, toggle the “+” key to “1/8” note and press the period key.

There is no universal symbol in tablature for the whole and half note. We have chosen the method we have seen most often. We use brackets around a quarter note to make it a half note, and the same symbol without the stem to represent a whole note. A dot behind the half note makes it a dotted half, or three count note.
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The plus key does not toggle between those note values. You will need to mouse click the “Whole” “Half” or “Dotted Half” icon. You can toggle back to quarter notes by using the plus key.

Entering Fret Numbers

Once you have selected the string where you want the fret number entered, and have the desired note value selected, type the fret number using the numbers on the numeric keypad, and press <ENTER>.  IMPORTANT-  <NUM LOCK> must be enabled in order to enter tablature from the numeric keypad!

Slurred Notes

There are many different ways people use to represent slurs (hammer-ons, pull-offs and slides.)  For some examples, check the Chapter 2. DO NOT USE THE TIE MARK (^) FOR SLURS. It will not play the second note of the slur on the MIDI playback.  If you want to use a slur rather than a dash, the equal (=) sign will display as a slur mark, and will not affect the playback function.

For method number one (using a dash between the slurred notes), use a hyphen between the two numbers.  For example, if you want a slide from the second fret to the fourth fret on one single stem, type “2-4” and press <ENTER>. If you want each number on a separate stem, type “2-” and <ENTER>, then type “4” and <ENTER>. You can also enter more than two notes, i.e. “0-2-0” then <ENTER>.
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If you prefer to use a slur mark instead of the dash, use the equal (=) sign between the numbers.  It can be used on slurs that occupy the same stem or different stems for each number. (See the section on slurs in the “Explanation of Tablature” in chapter 2).

Rests
To enter a rest, toggle the plus key or mouse click to choose the time value you want, then select Rest from the Symbols Menu, click rest on the button bar, or use the <F4> shortcut key.  If you want a half rest, either select Half Rest from the Symbols menu or press Ctrl + H. For a Whole rest, select Whole Rest from the Symbols menu or press Ctrl + W.

Multiple Notes (Stacked notes)

To enter two or more notes stacked one above the other (to be played simultaneously), select the desired note value, position the cursor on the string with arrow keys or mouse, and type in one of the numbers.  Without pressing the <ENTER> key, move the cursor up or down and put in a second number. A stem will appear on the numbers after entering the second number. Disregard this, and continue adding numbers for as many notes as are played together.  When all of them have been placed on the staff correctly, press <ENTER>. At this time, the correct time value will be attached to the stem.

Muted Notes

Muted or ‘dead’ notes are usually represented by an “x” in the location you would normally play the note.  Use the same procedure as you would to enter a number, select note value and string number, but type in an “x” instead of the fret number, and press <ENTER>. Be aware that the MIDI playback does not recognize the muted note. It will just read it as an open note on the string where it is placed. 

Tied Notes

To create a tied note, type in the first number of the tied note, before you press the enter key, press “^”  (shifted 6) then <ENTER>, then enter the note it is to be tied to and press <ENTER>.
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It is possible to tie stacks of notes, but each must be entered by typing in the number followed by “^” (Shift + 6)

You may also want to tie over one of the notes and not another, so that one will sustain and the other will not. That may also be done. The example shows both of these instances.
Some people prefer to use parenthesis to denote a tie. If you choose to do that, just put parenthesis around the number when you enter it. You should be aware that the MIDI playback function does not recognize this method. It will ignore the parenthesis, so you may want to use one method for your printouts and another for our playback. 

String Bends

A string bend is designated by an upward bending arrow placed behind a number.  To do this, type in the number, then press the “>“ and press <ENTER>.  A release is designated by a downward arrow placed after a number (or if you prefer, by itself, on a stem). To do this, use the same method as before except use the “<“ key.

Entering and Changing Chords

· Click Edit Menu

· Click Chords or use 

      Short-cut key <F1>

· Type in chord name

· Press <ENTER>

Chords are entered above the staff as in standard notation.  To enter a chord, move the cursor to the number under which you want the chord placed.  Select “Chords” from the “Edit” Menu (or use the shortcut key, <F1>).  This moves the cursor above the staff to the chord position.  Type in the chord name the way you want it to appear in print, and press <ENTER>. The MIDI playback does not play back the chords written above the staff. If you want it to play back a chord, the chord will have to be entered as stacked notes in the tablature staff.

If you want to erase the chord, select Chords from the Edit Menu, or press <F1>.  The chord will be removed.  The cursor will be left above the staff in case you want to enter in another chord.  Press <ENTER> and the cursor will drop back to the staff.

Harmonics
· Position the cursor on the note under which the harmonic is to be entered

· Click Edit Menu

· Click Chords


or

      Short-cut key <F1>

· Type “*”

· Press <ENTER>

Harmonics are designated by placing an asterisk above the number you want to be played as a harmonic.  These are entered by the same method used to enter the chords.  Position the cursor on the note under which the harmonic is to be entered.  Select Chords from the Edit Menu or press <F1>.  Type an asterisk and press the <ENTER>  key.  To remove an unwanted asterisk,  simply press <F1> again and it will be removed.  Press <ENTER> and the cursor will return to the staff.

Remarks

· Click Edit Menu

· Click Remarks

· Type in your remark

· Press <ENTER>

The remarks line is a place above the staff and just above the chord line.  It can be used as a place to label a section or whatever you choose.  Some examples are: “SOLO,” “Section 1,” “Chorus, “Bridge,” etc..  To do this, select Remarks from the Edit Menu.  A box will open with a cursor at the beginning of a text box.  Type in your choice of editing remark.  Click OK and the remarks will be placed above the staff. Remarks can be justified to the end of the measure instead of the beginning, by entering a “/” in front of your entry.
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Lower Staff Editing Marks

 Right-Hand Editing
· Click Edit Menu

· Click Right-Hand Editing

or

      Short-cut key <F2>

· Type in letter

· Press <ENTER>

Left-Hand Editing
· Click Edit Menu

· Click Left-Hand Editing

or

      Short-cut key <F3>

· Type in letter

· Press <ENTER>

There are two data entry lines below the staff.  The one just below the staff is for left-hand editing.  It can be used to describe the left-hand technique that the arranger expects of the performer.  A single character entry is all that is allowed below each number.  Tablature uses “P” to indicate a pull-off, “S” to indicate a slide or “H” to indicate a hammer-on.  There are other possibilities that vary between arrangers.  To enter an editors mark, move the cursor to the number under which you want the editors mark.  Select Left-Hand Editing from the Edit Menu or use <F3>. Type in the single character you want and press <ENTER>.

Right-hand editing is used for right-hand finger abbreviations such as “I” for index, “M” to middle, “T” for thumb, “A” or “R” for angular and ring fingers, respectively.  These editing marks are entered just below the position the left- hand markings are entered.  They are entered the same way except you select Right-Hand Editing  from the Edit Menu, or press <F2>.
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These editing marks can be removed by using the entry procedure to position the cursor beneath the staff, on the mark you want removed, and pressing the space bar.

 Editing Tab        

Changing a Number

If you are entering tablature and realize the number you just entered is wrong, you can simply backspace and type in the correct number.  If you are scrolling backward or forward and want to change a number without changing time value or strings, move the cursor to the number you want to change (by either arrows or mouse) and type in the new number and press <ENTER>.  It will replace the old one.

 Changing a Number to Another String

If you are editing (rather than entering tab, where you may backspace to make corrections) and want to change a number to another string, move the cursor to the number you want to change.  Press the <DELETE> key.  The number will be erased, but the stem will remain.  Move the cursor to the string you want to place the new number (by either the up and down arrow keys or the mouse).  Type in the number.

Changing the Time Value of a Number

This is one of the easiest functions to do.  Simply move the cursor to the number, and click the time value button you want the number changed to, (or toggle the “+” key to the correct note value and press <ENTER>) and the number will re-flag and stem to the selected note value.

Deleting a Note

If you have an extra note you need to remove, using the <DELETE> key is not the solution, since it removes only the number and leaves the stem.  To remove a note from a measure, place the cursor on it and select Delete Note from the Edit Menu.

Inserting a Note

In the Edit mode, the cursor doesn’t go beyond the last beat in the measure. The only way to put another note into the measure is with the Insert Note function.  Position the cursor (either in front of or in back of) where you want to insert the note, and select either Insert Note Before or Insert Note After from the Edit Menu.  An empty stem will appear on the staff.  Move the cursor to the string you choose, and enter the number.  The note value will be the note value of the number where the cursor was previously located.  If you want the newly inserted note to have a different note value, just mouse-click the note value button of your choice.

Changing a Number to a Rest

To change a number to a rest, position the cursor on the number, and select Rest from the Symbols Menu, or use <F4>.  It will change to a rest of the same time value as the number it replaced.

Changing a Rest to a Number

To replace a rest with a number, move the cursor to the beat the rest is on, and move to the string where you want the number entered.  Type in the number you want and press <ENTER>.  The rest will be replaced by the number.  The time value will be the same as that of the rest you replaced.  If you desire a different note value, mouse-click the note value button of your choice.

Deleting a Measure

Occasionally you may want to eliminate a measure completely.  There are those times when starting over is faster than fixing what you’ve done.  Other times you may find you’ve inadvertently entered a measure twice.  To delete a measure, for whatever reason, you simply move to the measure you want to delete and select Delete Measure from the Edit Menu.  The measure will be deleted and the measures following it will be renumbered to reflect the change.

Inserting a Measure

If you have deleted a measure because you wanted to put another in its place, you will need to use the Insert Measure function.  To insert a measure, go to the measure following the place where you want to insert the measure.  For example: You want to insert a measure between the current second and third measure.  Go to measure number 3.  Select Insert Measure from the Edit Menu.  You’ll get an empty measure number three.  Notice that the Next Measure and Previous Measure buttons have changed to OK and Cancel.  Enter the replacement measure the way you want it to appear in the song.  When you have it entered, click OK, and all subsequent measures will be renumbered accordingly. IMPORTANT- After inserting all of the measure, it is essential that you click the OK button prior to entering other entries such as chords, repeat brackets, and lower staff editing marks. They can be added after clicking the OK button.    

If you change your mind about inserting the measure, prior to completing the operation, you can click the Cancel button and return to the measure from which you began the insert procedure.  You cannot insert a measure as the last measure of the song.  For this purpose you must use the Append feature.  (See the Append Section.)

If you are inserting a measure before you are done entering the song, to continue with the rest of the song YOU WILL NEED TO SELECT APPEND from the file menu. The insert measure function is an editing procedure, and Tabrite will assume you are done with the song and will loop back to measure one rather than  proceeding the next measure.

Entering a Partial Measure

Sometimes a song begins with a pickup measure (a measure with fewer beats than the rest of the song). To do this, just click the Next Measure button when you are finished entering the measure the way you want it to appear.

Sometimes the last measure of a song is an incomplete measure.  To enter an incomplete measure at the end of a song, select Double bar from the Endings Menu, or press <F9>, and the measure will close with however many beats you have in it at the time.

Hard Line Break
A hard line break is a function that moves you to the next line, regardless of the number of measures you have on the current line. The purpose of this could be to separate sections of a song. To use this function, select “Hard Line Break” from the “Edit” menu. This will automatically direct the program to put the current measure on a new line when the song prints out. To remove the hard line break, go to the measure where you inserted the break and select “Hard Line Break” from the “Edit” menu. That will toggle the function off.

Copy, Paste and Copy to Clipboard

If you are entering a song and find that a measure, or several measures, you have already entered are repeated, you may want to use the copy and paste function rather than entering the measures again. Make sure you are in the measure of the song where you would like the copied measures to follow. Select “Copy” from, the “Edit” menu. A box will open prompting you for the start and end measures. Enter the measure number where you want to begin the copy then the last measure you want copied and click OK. If you only want only one measure copied, the start and end measure will be the same. 

From the “Edit” menu, select paste, and the measure or measures you have copied will be pasted in the measure following the place you are in the song.

If you want to copy a section of a song into another program such as Word or Word Perfect, from the display window (using either the small or large view) click and drag a box around the section you want copied, and select “Copy To The Clipboard” from the “Edit” menu. Open the program where you would like the section imported and select paste from the menu of the program you are importing to.

Musical Symbols & Endings

Repeat Signs
· Click Symbols Menu

· Click Repeat Sign (or Repeat Start)


or

      Short-cut Key <F6> ( or<F8>)

A repeat sign consists of a double bar and double dots.  To put a repeat sign at the end of a measure, while in the measure, select Repeat End from the Symbols Menu.  You can also use <F6>.  To remove the repeat sign press  <F6> again.  

A repeat sign at the beginning of the measure is used to designate the place where a song is repeated from.  To enter a repeat sign at the beginning of a measure, while in the measure, select Repeat Start from the Symbols Menu or use <F8>.  Repeat the process to remove the sign.

Repeat Brackets

· Click Endings Menu

· Click Repeat Brackets

· Type in ending number

· Press <ENTER>

Repeat brackets are used to designate first and second endings (or third endings, etc.)  To do this, make sure you are in the measure where you want the bracket entered.  Select Repeat Brackets from the Endings Menu, or use <F7>.  The bracket will appear above the staff with the cursor in the left-hand corner.  Type in a “1” or “1.” or “2” or “1.2.” or whatever you prefer, and press <ENTER>. To remove the repeat brackets, simply press  <F7> again.

Double Bar

· Click Symbols Menu

· Click Double Bar (or Double Bar Start)


or

      Short-cut key <F9> (or <F12>)

A double bar is used to designate the end of a song or section of a song.  To enter double bars, be in the measure where you want them and select Double Bars from the Symbols Menu or use the <F9>.  To remove the double bars, simply  press <F9> again. 

A double bar can be entered at the beginning of the measure by selecting Double Bar Start from the Endings Menu, or use <F12>.

Sign

Fine

D.C.

D.S.

D.C. al Fine

D.C. al Coda

D.S. al Fine

D.S. al Coda

Coda

To enter any of these musical terms, be in the measure where you want it entered. IMPORTANT NOTE- When you enter your selection, it will appear on the screen, as if it were in the next measure, but it will print in the current measure.  Entering any of these terms may be done by selecting it from the Endings Menu, or with the short-cut key. They are:




<Shift +F5>
Sign




<Shift+F3> 
Fine




<Shift+F1> 
D.S. al Fine




<Shift+F2>
D.C. al Fine




<Shift+F6>
D.S. al Coda




<Shift+F7>
D.C. al Coda




<Shift+F9>
D.C.




<Shift+F8> 
D.S. 




<Shift+F4> 
Coda

To remove them use the same procedure you used to enter them.  If you want to replace one with another, it isn’t necessary to remove one first before entering the replacement. When you enter one in the same measure where one is already entered, it will replace the old one.

The Sign

· Click Endings Menu

· Click Sign


or

Short-cut key <Shift+F5>

Coda Mark
· Click Endings Menu

· Click Coda


or

      Short-cut key <Shift+F4>

These musical symbols are entered by selecting the one you want from the Endings Menu, or using the short-cut keys.  <Shift+F5> for the Sign, or the <Shift+F4> for the Coda Mark.  To remove either of them use the same method used to enter them.

[image: image54.png]Remarks:

=

[7Ta Coda





To Coda
The “To Coda” is usually entered above the end of a measure. It can be entered in the remarks. Select Remarks from the Edit Menu. An entry box will open. To get the “To Coda” to enter at the end of the measure, type “/To Coda.” The slash will justify the remark to the end of the measure.
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The Strum Mark
The strum mark is used to denote a brush across all of the strings. The chord above the staff is held and the strum mark is sometimes used in place of writing out all of the numbers on each string of the chord. 
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To enter the strum mark, select the time value you want the strum mark to occupy. It doesn’t matter which string you are on when you enter the strum. It will automatically position itself in the center of the staff. Press the forward slash mark on keyboard or the numeric keypad.  A small slash mark will appear on the staff. Press  <ENTER> and the full size strum character will appear centered in the staff.

The MIDI playback does not recognize the strum slash mark. If you want the chords to play back through the MIDI, you will need to enter the chords as stacked notes in the tablature staff.

Troubleshooting

Invalid Property Value

If you have stored some Tabrite files on a floppy disk, saved them with a particular font, and deleted that font from your system, when you try to open that file, you will receive the error message, “Invalid Property Value.”

Subscript out of Range
This error message usually results from exceeding the data entry limit. (see page 4 of the manual) This error can also occur when you delete every note of the song and attempt to do anything other than add a note. An easier method is to select “New” from the file menu and start over.

Run Time Error 9

This means the MIDI is in a loop looking for a second ending, sign, coda or “to coda” mark that you forgot to enter. 

Printout is different than screen display
Unpredictable results can be obtained by entering musically incorrect measures. Tabrite will automatically close a measure when it has the correct number of beats in the measure, but it is possible to put in too many. If you have 7 eighth note in a measure, there is still room for another eighth note, so the measure has not closed. If you enter a quarter note, the measure will close with 4 and a half beats in it. This type of note entry can result in problems in the print. Tabrite assumes that its user is somewhat musically literate. If you have trouble entering the right time values, you should consider a music theory book to aid your musical accuracy.

SAVE YOUR WORK PERIODICALLY in case a problem arises and the program unexpectedly exits. It is particularly wise to do so before you send the file to the printer. If a printer problem causes the program to exit, all of you work could be lost.

Cursor is blinking but you cannot enter numbers on the staff lines.

Make sure the num locks key is turned on.

No sound from the midi player

Check the Midi Setup under the MIDI menu. Make sure the sound output device you are using is selected.
Sound is a rather tricky item.  Sound cards work similar for various cards, however the set up is not identical in all cases.  Tabrite will make  a .MID file, then will play that back through your sound card.  This is NOT  the same as the sounds from a computer game, which are usually .WAV files.  Follow instructions in your sound card manual to insure the MIDI files will work.

You can check the operation of .MID files in general through the Windows Media player and a .mid file such as “Canyon.Mid”, usually included with Windows.

If you are playing back through a synthesizer, the sound you select on the Tabrite midi player may not be the sound you get on the synthesizer. Make your adjustments in sound on the synthesizer. 

Display Problem- Tabrite enters numbers one line below where you entered the numbers.

It is likely that you selected the “Tab” fonts from the “Font Select” file menu. The tab fonts are the fonts the program uses to create rests, repeats, flags, etc. Selecting another font should correct the problem.

Other Problems 

If you minimize the midi player and then minimize Tabrite, re-open Tabrite, the midi player will still be open in a window behind Tabrite. If you try to open another midi player, it will not work. You cannot have two midi players open at the same time. The safest procedure is to close the midi player if you are going to minimize Tabrite.

Most of the Problems users have encountered with Tabrite, are in the troubleshooting section. They are usually quickly detected and cured. The user errors are usually overcome with experience at entering tablature.

Technical Support

Not available for the freeware version
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Alternate Tunings

If you want to use a tuning other than the default (standard) tuning, choose the “tuning” selection from the “Midi” menu. The tuning screen will open displaying a diagram of the  instrument you have selected. Click the arrow above the diagram, and a drop-down menu will offer a choice of tunings. For example, the guitar tunings are: Standard, Dropped D, Open D and G. Mouse click your choice, then click the “Exit” button. This choice will stay in effect until you change your selection or exit the program. When you re-open the program, the default tuning will be in effect again.   

The tuning selections for the Banjo are: Bluegrass G, Banjo C and Banjo D.

The tuning selections for the Bass/Mandolin (4 string instruments) are: Mandolin, Tenor Banjo, Ukulele, Bass, Plectrum Banjo and Baritone Uke. 

Custom Tuning or Adding a Tuning to the List

If you are using a tuning other than one of the choices available, you can custom tune to any tuning you want. Just open the tuning screen for the instrument you are working with. There is a pitch number displayed in the box at the end of each string. These numbers represent the pitch and octave used as the international standard for midi. You may mouse click the box for the string or strings you wish to change and enter the number you want. Increasing the number by one, raises the pitch of the string by a half step. Lowering the number drops the pitch by a half step for each number. We have included a diagram of a piano keyboard with the keys numbered. If you need it, you may use this as a guide for you to select the number for the pitch you want entered on each of the strings. When you have entered the numbers of the pitches you want for each string, mouse click in the “Tuning Name” box and type in the name you would like to call the tuning. Click the “Add” button. This will add the tuning to the list on the drop-down menu. If you want this tuning saved so that it will permanently be on the list of tunings, you must also click the “Save” button after you have added it to the list. If you do not, it will not be on the list the next time you open the program, and will have to re-enter it if you want to use it again.

Deleting A Tuning

If there is a tuning that you never use, you may choose to delete it from the tuning menu. To do that, select the tuning you want deleted, and click the “Delete” button. To make sure that this change stays in effect when you re-open the program, you must also click the “Save” button before exiting the tuning screen. 

Changing the Default

Perhaps the default tuning is not the tuning you use most often. If that is the case, you may want to change the default. Select the tuning you want (or create and add the tuning to the list, then select it) and click he default button. The program will now open with the new default. 

Tabrite creates a “tun” file (strings6.tun, strings5.tun and strings4.tun) the first time you use the tuning screen, and places this file in your Tabrite directory. This file contains your current tuning list and defaults for each instrument. If you delete these files, Tabrite will re-build them the next time you use the tuning screen, but it will rebuild them with the original list and defaults. Be aware of this in case your files are destroyed. If you have made numerous changes to your tuning screen, it is a good idea to back up these files as well as the songs you enter.
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Changing the Sound of the Playback Instrument

You can change the sound of the instrument being played. There is a drop-down menu above the “Play” button on the midi screen. Choose the sound you prefer, or experiment with different sounds on different songs. ( Make sure you read the problems section below, to avoid problems with the “instrument change” feature.) 

How to Avoid Playback Problems on the Midi Player

Remember that a sound card or a midi playback device such as a synthesizer is required to use Tabrite’s Midi playback function. 

There is a specific way to enter tab that is recognized by the midi player. Any deviation from that can result in some unpredictable results. 

· Enter slurs such as hammer-ons, pull-offs and slides using a dash (or an equal sign , if you prefer a slur mark instead of the dash)  between the two numbers, not a tie mark. A tie mark is used to connect the length of the  note to the duration of the two notes combined.

· Do not use slurs of more than two notes on a single stem. For example, if you have a quarter note stem with a three note slur, just enter them as eighth note triplets with a dash between each of them.

· Do not use parenthesis for tied notes. The midi player only recognizes the slur line as a tie.

· If you forget to enter a sign  or a “Fine,” but do enter “DS al Fine,” the program will hang up looking for the end of the song, and you will have to Exit the program with Ctrl  + Alt + Delete. Make sure all correct markings are in before playing the song. 

· The “To Coda” must be entered exactly as described in the manual or the midi player will cause the program to hang up. 

· If you are using ending brackets with more than one number in each bracket, the program will play it back recognizing only the first number.

· The guitar slash, or strum mark is not recognized. The midi player will play it as a single note only. If you want the chords to play, you will have to enter each note of the chord in tablature. 

· String bends are represented by an arrow, which is only a graphic, and is note played on the midi player. You can loosely duplicate the string bend by entering the note where the bend begins, followed by a dash, then the note where the bend ends. It may sound a little like a slur, but work adequately for playback purposes. The muted note (x) is also not recognized by the MIDI playback. It is strictly graphic. 

· Do not stop the midi player while the song is being played and change instrument sounds. The resulting sounds will be a little strange. You can change instruments sounds while the song is being played, without clicking the “Stop” button, or you can wait until the end of the song.   
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